Passa ai contenuti principali

Panoramica di BitLocker: Sicurezza della rete, Protocollo TLS (Transport Layer Security)

Prevent data theft with BitLocker Management | TruGrid

Questo argomento per i professionisti IT descrive il funzionamento del protocollo TLS (Transport Layer Security) e fornisce collegamenti a RFC IETF per TLS 1.0, TLS 1.1 e TLS 1.2.

Nota

In una versione futura di Windows Server, TLS 1.0 e 1.1 verranno disabilitati per impostazione predefinita. Per altre informazioni, vedere Risorse di disabilitazione versioni TLS 1.0 e 1.1.

I protocolli TLS (e SSL) si trovano tra il livello del protocollo dell'applicazione e il livello TCP/IP, in cui possono proteggere e inviare i dati dell'applicazione al livello di trasporto. Poiché i protocolli funzionano tra il livello dell'applicazione e il livello di trasporto, TLS e SSL possono supportare più protocolli a livello di applicazione.

TLS e SSL presuppongono che sia in uso un trasporto orientato alla connessione, in genere TCP. Il protocollo consente alle applicazioni client e server di rilevare i rischi di sicurezza seguenti:

  • Manomissione dei messaggi

  • Intercettazione dei messaggi

  • Messaggio falso

I protocolli TLS e SSL possono essere suddivisi in due livelli. Il primo livello è costituito dal protocollo dell'applicazione e dai tre protocolli di handshake: il protocollo handshake, il protocollo delle specifiche di crittografia delle modifiche e il protocollo di avviso. Il secondo livello è il protocollo di record.

Livelli di protocollo TLS e SSL

SSP Schannel implementa i protocolli TLS e SSL senza modifiche. Il protocollo SSL è proprietario, ma internet Engineering Task Force produce le specifiche TLS pubbliche. Per informazioni sulla versione TLS o SSL supportata nelle versioni di Windows, consultare la sezione Protocolli in TLS/SSL (SSP Schannel). Ogni specifica contiene informazioni su:

  • Protocollo di record TLS

  • Protocolli di handshaking TLS: - Modificare il protocollo di specifiche di crittografia - Protocollo di avviso

  • Calcoli crittografici

  • Pacchetti di crittografia obbligatori

  • Protocollo dati di applicazione

RFC 5246 - Protocollo TLS (Transport Layer Security) versione 1.2

RFC 4346 - Protocollo TLS (Transport Layer Security) versione 1.1

RFC 2246 - Protocollo TLS versione 1.0

Ripresa della sessione TLS

Introdotto in Windows Server 2012 R2, il provider di servizi condivisi Schannel ha implementato la parte lato server della ripresa della sessione TLS. L'implementazione sul lato client di RFC 5077 è stata aggiunta in Windows 8.

I dispositivi che connettono TLS ai server devono riconnettersi spesso. La ripresa della sessione TLS riduce il costo previsto per stabilire le connessioni TLS perché la ripresa implica un handshake TLS abbreviato. Ciò consente più tentativi di ripresa permettendo a un gruppo di server TLS di riprendere le sessioni TLS. Questa modifica offre i seguenti vantaggi per qualsiasi client TLS che supporta RFC 5077, inclusi i dispositivi Windows Telefono e Windows RT:

  • Riduzione dell'utilizzo di risorse nel server.

  • Riduzione della larghezza di banda, che determina un miglioramento dell'efficienza delle connessioni client.

  • Riduzione del tempo impiegato per l'handshake TLS a causa delle riprese della connessione

Per informazioni sulla ripresa della sessione TLS senza stato, vedere il documento IETF RFC 5077.

Negoziazione del protocollo applicativo

Windows Server 2012 R2 e Windows 8.1 hanno introdotto il supporto che consente la negoziazione del protocollo dell'applicazione TLS lato client. Le applicazioni possono sfruttare i protocolli come parte dello sviluppo dello standard HTTP 2.0 e gli utenti possono accedere a servizi online come Google e Twitter utilizzando app che eseguono il protocollo SPDY.

Per informazioni sul funzionamento della negoziazione del protocollo dell'applicazione, vedere Transport Layer Security (TLS) Application Layer Protocol Negotiation Extension.For information about how application protocol negotiation extension, see Transport Layer Security (TLS) Application Layer Protocol Negotiation Extension.

Supporto TLS per le estensioni di Indicazione nome server

La funzionalità Indicazione nome server (SNI, Server Name Indication) estende i protocolli SSL e TLS per consentire la corretta identificazione del server quando su un singolo server sono in esecuzione numerose immagini virtuali. In uno scenario di hosting virtuale, diversi domini (ognuno con il proprio certificato potenzialmente distinto) sono ospitati in un solo server. In questo caso, il server non ha modo di sapere in anticipo quale certificato inviare al client. SNI consente al client di informare in anticipo il dominio di destinazione nel protocollo e questo consente al server di selezionare correttamente il certificato appropriato.

Questo fornisce la seguente funzionalità aggiuntiva:

  • Consente di ospitare più siti Web SSL in una singola combinazione di protocollo Internet e porta.

  • Riduce l'utilizzo di memoria quando più siti Web SSL sono ospitati in un singolo server Web.

  • Consente a più utenti di connettersi ai siti Web SSL contemporaneamente.

fonte

Commenti

Posts piú popolari

Windows 12 punta alla multimedialità grazie all’integrazione dell’intelligenza artificiale.

Windows 12 sarà fortemente orientato alla multimedialità grazie all’integrazione dell’intelligenza artificiale, al supporto per chip dedicati (NPU) e a un’interfaccia riprogettata che migliora l’esperienza visiva e sonora. Il lancio è previsto per ottobre 2025, con aggiornamento gratuito per chi possiede licenze attive di Windows 10 e 11 . Focus sulla multimedialità Intelligenza artificiale integrata : funzioni come “Copilot” e IA locale ottimizzeranno editing video, fotoritocco e gestione audio. Supporto hardware avanzato : sfrutterà NPU (Neural Processing Unit) per accelerare calcoli legati a grafica e multimedia. Interfaccia rinnovata : nuova barra delle applicazioni mobile e design più fluido per gestire contenuti multimediali in modo intuitivo. Esperienza modulare : Windows 12 sarà adattabile ai diversi dispositivi, dai PC da gaming ai laptop ultraleggeri, con particolare attenzione a prestazioni grafiche e compatibilità. ...

Perché è necessario tanto tempo per installare Office in Windows 10?

I problemi riscontrati quando si prova a installare Office 2016 o Office 2013 e le relative correzioni variano a seconda che il prodotto sia incluso in un piano Office per utenti privati o Office per le aziende. Inoltre, con i piani Office per le aziende, solo gli amministratori responsabili della gestione di Office 365 nell'organizzazione possono eseguire alcune attività. Quindi, gli amministratori devono visualizzare i problemi e le soluzioni elencati nelle schede Office per le aziende e Amministrazione di Office 365. Se viene visualizzato il messaggio di errore La connessione è lenta, potrebbe volerci qualche minuto oppure se l'installazione di Office richiede tempi molto lungi o sembra bloccarsi, è consigliabile annullare l'installazione e quindi provare con alcune procedure seguenti. L'installazione di Office impiega molto tempo. Contenuto del post: [ hide ] Si ha una stampante HP 4500 o HP 8500 OfficeJet e si installa Office o Office 365? In questo caso,...

Guida a Windows 11: Usare OneDrive nei dispositivi Android e iOS

OneDrive è un potente strumento che consente di archiviare, condividere e accedere ai file ovunque ci si trovi. Con l'app OneDrive per dispositivi mobili è possibile mantenere i file a portata di mano nello smartphone o tablet. Questa guida illustra i passaggi per iniziare a usare OneDrive nel dispositivo mobile. Per iniziare Scaricare e installare l'app OneDrive Per i dispositivi Android Aprire Google Play Store sul dispositivo Android. Cercare OneDrive. Toccare Installa per scaricare e installare l'app. Per altre informazioni sull'uso di OneDrive nel dispositivo Android, vedere Dispositivi mobili e Mac per OneDrive . Per dispositivi iOS Aprire il App Store sull'iPhone o sull'iPad. Cercare OneDrive. Toccare Ottieni per scaricare e installare l'app. Accedere a OneDrive. Aprire l'app OneDrive. Toccare Acc...

Come installare Windows Media Player 11 in Windows Seven.

Windows Media Player 11 è un riproduttore audio e video dotato di una libreria completa e di molte funzioni extra. La ragione principale di questi discutibili rimpianti è la mancanza della toolbar che consente una facile gestione del player attraverso la taskbar del sistema (in Seven sostituita dai controlli avanzati che saltano fuori posizionando il cursore del mouse sul pulsante di WMP 12 ), ma qualcuno ha anche lamentato problemini di varia natura sparsiqua e là per il programma. .  Ad ogni modo, di seguito trovate una guida su come installare Windows Media Player 11 su Windows 7 : Recarsi nel menu start , digitare services.msc nella barra di ricerca veloce e premere il tasto Invio. Leggi anche: Come installare Windows Seven Service Pack 1 Fare doppio click sul servizio chiamato Windows Media Player Network Sharing e stopparlo; Prendere il controllo completo della cartella X:\Program Files\Windows Media Player , dei file nella cartella X:\Windows\System32 il cu...

Cpme u tilizzare i tasti di accesso per il menu contestuale XAML in Esplora file in Windows 11

Questo tutorial ti mostrerà come utilizzare le scorciatoie da tastiera per il menu contestuale XAML in Esplora file e sul desktop in Windows 11. A partire dalla build 22621.1928 di Windows 11 , Microsoft ha aggiunto le scorciatoie da tastiera al menu contestuale XAML in Esplora file. Un tasto di scelta rapida è una scorciatoia da tastiera che consente all'utente di eseguire rapidamente un comando nel menu contestuale. Ogni tasto di scelta rapida corrisponderà a una lettera nel nome visualizzato. Fa parte dell'impegno di Microsoft per rendere Esplora file più accessibile. Ecco come: 1 Selezionare un elemento (file, cartella, unità, libreria) in Esplora file (Win+E) o sul desktop (Win+D). 2Premi il tasto menu sulla tastiera. 3Premi il tasto (es: "H") sulla tastiera corrispondente al tasto di accesso all'azione (es: "Apri con") nel menu contestuale che desideri utilizzare. fonte